Failed to find the pipeline named '__default__'

In order to get the best help, it is suggested to answer the following questions:

What is the goal you are trying to achieve?
Make kedro pipelines work again. Randomly (with the current kedro version working) this error arose and never disappeared. However with kedro new starters kedro still works.

What have you tried, in order to accomplish the goal?
Creating a new environment with only kedro did not solve the issue. Changing packages and trying to solve package dependencies didn’t work. Tried using this as reference kedro.framework.context.context.KedroContextError with Kedro 0.17.0 · Issue #677 · quantumblacklabs/kedro · GitHub

What version of Kedro are you using? (Use kedro -V)
Kedro 0.17.2

Do you have any custom plugins?
Kedro-mlflow

What is the full stack trace of the error (if applicable)
kedro.framework.context.context.KedroContextError: Failed to find the pipeline named ‘default’. It needs to be generated and returned by the ‘register_pipelines’ function.

Hi @ashots

Have you tried both solutions listed in here:

Id be curious to know if either solves your problem :slight_smile:

Hey @ljam,

The pipeline now works. I made a new 0.17.3 kedro project and moved my code over. I also did stronger dependency management as there were some conflicting versions between some packages.

Happy coding!