Installing kedro-great-expectations & kedro-glass

Hi all,
I would like to install kedro-great-expectation(=0.3.0, <0.4.0’) and kedro-glass(>=0.7, <1.0’) in RedHat.

Although I have tried to execute the following commands, I faced the same error.

  • sudo yum groupinstall 'Development Tools' → pip python -m pip install ‘kedro-great-expectations>=0.3.0, <0.4.0’
  • $ python -m pip install ‘kedro-great-expectations’
ERROR: Could not find a version that satisfies the requirement kedro-great-expectations<0.4.0,>=0.3.0
    ERROR: No matching distribution found for kedro-great-expectations<0.4.0,>=0.3.0

Could you please tell me the way to resolve this error and each function of these packages (kedro-glass & kedro-gret-expectations) if anyone knows?

If I haven’t provided enough prerequires (i.e. system env and existing installed packages), please kindly let me know it so that I will share any further info with you.
Any help would be appreciated!
@Minyus @DataEngineerOne

Hi @Asuka ,

I searched in the public PyPI (https://pypi.org/) , but I couldn’t find kedro-great-expectation or kedro-glass.
If kedro-great is the package you want, you can install the latest version by pip install kedro-great==0.2.7, but version 0.3.0 hasn’t been released yet.
Perhaps, you might want to set your private PyPI which includes those packages by --index-url option.

Reference:
https://pip.pypa.io/en/stable/reference/pip_install/#cmdoption-0

1 Like

Thank you for your reply @Minyus.
Yes exactly, what started it all was to execute the below “requirements.txt” file.

As a result to pip install above, we failed to success (neither ver15 nor ver16).

So that’s why we changed from installing from its link to one by one.

Once we will give what you mentioned a shot,
and we might raise another post if necessary! Thank you again!

Hello @Asuka,

Hope you are doing great! It sounds that you are talking about some proprietary QB packages that are not yet available to a public community. Could you please check packages/* in the root folder of your project - typically *.whl files should be there.

2 Likes

Thank you @drqb for your help.
Honestly, I haven’t recognized them as unpublished (Now I understood why I couldn’t find any articles or documents)!

As you mentioned, I checked its folder and confirmed these whl files.
And we could install all the packages to be needed including kedro-great-expectations and kedro-glass! The cause was that we had not executed correctly the command to install cbc-solver.

This issue would be closed, and I sincerely appreciate you, @Minyus, and QB!

2 Likes