$ Kedro run error with pipeline option

Hi all,

I would like to know the reason why I faced below.
As a result that I ran the following commands,

$ kedro run --pipeline pipeline_name
$ kedro run -pipeline=pipeline_name

unfortunately they returned the same error

Error: Got unexpected extra arguments (–pipeline pipeline_name)

I was able to run without its option, and its pipeline exists. Any thought?
Thank you!
@Minyus @waylonwalker

1 Like

Please make sure that you provide us with at least the version of kedro, python, plugins, and if you have done anything to change your cli module.


In order to get the best help, it is suggested to answer the following questions:

What is the goal you are trying to achieve?

What have you tried, in order to accomplish the goal?

What version of Kedro are you using? (Use kedro -V)

Do you have any custom plugins?

What is the full stack trace of the error (if applicable)

The first one looks correct to me.

The second one is not correct. The typical way that cli parsers work is that --arguments (two dashes) are for the full name of the argument, and a -option (single dash) is for a shorthand. Shorthand options can be stacked together for instance the tar api typically uses a number of options. tar -zxv. so with kedro -pipeline it will fail saying there is no -i option.

1 Like

Thank you for your reply.
We would like to complete to execute one of the pipelines, so we have tried what I wrote above.

  • Kedro version: 0.16.6
  • Python version: 3.7.9
  • Plugins: Probably there are some plugins
    (Is there any way to identify which ones are plugins?)

Also, there is not any other error msg than above.
Please kindly let me know if you need some additional info. Thank you so much!

What does your help look like.

kedro run -- help

Finally it worked by executing this command

$ kedro run --pipeline=pipeline_name

This question would be closed, and thank you so much for your help @waylonwalker :sparkles:

1 Like