Pip issue

In order to get the best help, it is suggested to answer the following questions:

What is the goal you are trying to achieve? Install kedro

What have you tried, in order to accomplish the goal? pip install kedro

What version of Kedro are you using? (Use kedro -V) none yet

Do you have any custom plugins? no

What is the full stack trace of the error (if applicable)

pip install kedro

image

1 Like

Also tried pip install ‘kedro>=0.17.0’

I use Python only in Linux Docker containers.
Hope another Windows user can help.

Hello @yosty :slight_smile: Welcome to the Kedro Community!

It is awesome to have you here!

Before the installation, I want to remind you that we recommend the use of virtual envs, just to reinforce best practice. If you’re a newbie (as I am) this video series might help a bit understanding it :slight_smile:

Install

  • Using pip, this blog post describes the Kedro installation on Windows quite neatly. Some good hints on troubleshooting.

  • And if you consider using conda (my personal prefered way to install Kedro on a Win machines) the steps on the docs will get you there.

And since we love to know more about our community! Come and say hello on the Hey, introduce yourself! page.

Let us know how you get on with it. :slight_smile:

1 Like

What Python version are you using?

Not a fan of anaconda. Will not be installing it on my machines. Any help would be great on utilizing pip.

1 Like

Hey @yosty, I’m a bit late tto the party here, I’ve seen this error several times before myself. Looks like your version of python is one too high for kedro currently. You can find the compatible python versions of any pypi package by checking pypi.

PyPi shows that you need 3.6, 3.7, or 3.8
image

Since you are not a big fan of conda you can use pyenv. I have not used it myself outside of CI where its just under the hood. Real Python has a great article on pyenv that you can follow to get one of the compatible versions of python installed.

2 Likes

Downloaded 3.8 and it worked. Thanks !

1 Like

@yosty Great news! Glad it is working for you. Let us know if you run into any other issues. This community and Stack Overflow are both quite responsive.

1 Like